Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 14, 2026 - 05:00 UTC
Scheduled
Phenom will be performing scheduled maintenance to optimize the performance of platform services in the Production environments of the US, Ireland, Canada and India regions, along with the Staging environment of the US, Ireland and Canada regions. Please be advised that there will be scheduled downtime during which users may experience intermittent issues with login and access to platform applications in the Production environments of US and India regions. Additionally, there will be delays in Hiring Status updates and JobSync in the Production and Staging environments of US, Ireland and Canada regions.
Duration: Feb 14th, 2026 from 12:00 AM ET to 04:00 AM ET.
Posted Feb 12, 2026 - 14:28 UTC
This scheduled maintenance affected: Platform (Platform-US, Platform-IN), Jobpull (IX) (Jobpull-EU, Jobpull-CA, Jobpull-Staging-US, Jobpull-Staging-EU, Jobpull-Staging-CA), and Hiring Status (IX) (Hiring Status-EU, Hiring Status-CA, Hiring Status-Staging-US, Hiring Status-Staging-EU, Hiring Status-Staging-CA).