Delays in Recruiter initiated apply - All regions

Incident Report for Phenom

Resolved

Phenom engineering team has monitored and validated the Recruiter Initiated Apply functionality, and it is working as expected. Please log a support ticket if you continue to experience any issues.
Posted Aug 11, 2026 - 08:28 UTC

Monitoring

Verbiage : The Phenom Engineering team has resolved the issue impacting the Recruiter Initiated Apply functionality. We will be monitoring the fix and will keep you posted accordingly.
Posted Aug 11, 2026 - 07:39 UTC

Identified

Phenom identified an issue impacting the Recruiter Initiated Apply functionality wherein delays are being observed.
Team is actively working towards resolving this on priority, we will keep you posted on the progress.
Posted Aug 11, 2026 - 07:23 UTC
This incident affected: CRM (RX) (CRM-US, CRM-EU, CRM-CA, CRM-IN).