Intermittent Issues with career Sites

Incident Report for Phenom

Resolved

The Phenom team has resolved the intermittent issue that was affecting certain Career sites.
If you continue to experience any issues, we recommend clearing your browser cache.

Should the issue persist, please log a support ticket for further assistance.
Posted Jul 24, 2025 - 16:30 UTC

Investigating

Phenom team has identified an intermittent issue that may be affecting certain Career sites. Our engineering team is currently investigating and working towards a resolution.
Posted Jul 24, 2025 - 15:36 UTC
This incident affected: External Career Sites (CX).