CRM Automation delay in Prod US region
Incident Report for Phenom
Resolved
Phenom has resolved the issue with automation delay in the CRM and it is now functioning as expected.
Posted May 02, 2024 - 19:29 UTC
Identified
The Phenom team has identified the issue and is working on the fix.
Posted May 02, 2024 - 19:23 UTC
Investigating
We are currently facing a 10-20 minutes automation delay in the CRM. Our team is investigating the root cause. Next update will be shared in 30 minutes.
Posted May 02, 2024 - 18:39 UTC
This incident affected: CRM (RX) (CRM-US).