Email delivery latency for Scheduling

Incident Report for Phenom

Resolved

Email delivery latency for Scheduling has been fixed by AWS and their status page reflecting the same. Our Engineering team has validated our services and it is working as expected. Please log a support ticket in case you still see any issues.
Posted Jan 23, 2026 - 05:48 UTC

Monitoring

Customers using the Scheduling feature may experience email delivery delays on the US, Ireland, Canada, and Clean room regions due to increased processing times within AWS. We will keep you updated as we receive additional information from AWS.
Posted Jan 22, 2026 - 22:38 UTC
This incident affected: Scheduling (Scheduling_US, Scheduling-EU, Scheduling-CA, Scheduling-CR).