Proactive Notification - Issues with Careersites due to a Cloudflare scheduled maintenance

Incident Report for Phenom

Resolved

Phenom engineering has been monitoring the Cloudflare status page, as per the latest update, the issue impacting career sites has been resolved. All sites are now functioning as expected. Please log a support ticket in case you still see any issues.
Posted Dec 05, 2025 - 13:23 UTC

Monitoring

Phenom has identified an issue with Careersites due to a Cloudflare scheduled maintenance, Some of the clients using Cloudflare may experience intermittent issues accessing Careersites. Please reach out to Cloudflare for additional support or information. You can also track the outage status at: https://www.cloudflarestatus.com/

Phenom Engineering is monitoring the Cloudflare status page, and we will update you on the progress accordingly.
Posted Dec 05, 2025 - 09:30 UTC
This incident affected: External Career Sites (CX).