Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 31, 2026 - 05:00 UTC
Update
This is to inform you that, in addition to the previously communicated scope, Engineering will also be performing maintenance on Staging environments across all regions during the same window. Users may experience intermittent access issues on Staging environments during this period.
Posted Jan 30, 2026 - 09:00 UTC
Scheduled
Phenom will be performing scheduled maintenance to optimize the performance of platform services in the Production environments of the US, Ireland, and CR regions, along with the Staging environment of the Ireland region. Please be advised that there will be a scheduled downtime during which users may experience intermittent issues with Search and Scheduling in the Production US and Ireland regions. Additionally, users may encounter intermittent issues with Scheduling in the Production CR region and Ireland Staging environment.
Duration: Jan 31st, 2026 from 12:00 AM ET to 04:00 AM ET.
Posted Jan 29, 2026 - 15:25 UTC
This scheduled maintenance affected: Scheduling (Scheduling_US, Scheduling-EU, Scheduling-CR), Scheduling-Staging (Scheduling-Staging_EU), Platform (Platform-Staging-US, Platform-Staging-EU, Platform-Staging-CA, Platform-Staging-IN), and Search.