Intermittent Apply Issue with Russian Data centre

Incident Report for Phenom

Resolved

Phenom Engineering team has resolved the apply issue with the Russian subtenant, and it is working as expected. Please log a support ticket in case you still see any issues.
Posted Dec 19, 2025 - 07:21 UTC

Identified

Phenom team has identified an intermittent apply issue with the Russian subtenant. Phenom Engineering team is currently investigating the issue and We will keep you posted on the status.
Posted Dec 19, 2025 - 06:59 UTC
This incident affected: Apply(IX) (Apply-US, Apply-EU, Apply-CA, Apply-IN).