Intermittent Issues with Career Sites in All Production environments

Incident Report for Phenom

Resolved

Phenom team has resolved an issue affecting Career Sites header across all Production environments. If you continue to experience any issues, please log a support ticket for further assistance.
Posted Apr 02, 2026 - 11:18 UTC

Monitoring

Phenom team has resolved an issue affecting Career Sites where users are unable to view the header menu across all Production environments. Phenom Engineering is currently monitoring the fix and will provide another update shortly.
Posted Apr 02, 2026 - 10:46 UTC
This incident affected: External Career Sites (CX).