Apply Issue for Taleo customers

Incident Report for Phenom

Resolved

The Phenom team has applied a fix for the issue affecting the Hosted Apply feature for customers on Taleo and it is working as expected.
Please log a support ticket in case you still see any issues.
Posted Mar 20, 2025 - 20:54 UTC

Monitoring

The Phenom team has applied a fix for the issue affecting the Hosted Apply feature for customers on Taleo. We will be monitoring it for the next 30 mins.
Posted Mar 20, 2025 - 20:23 UTC

Identified

The Phenom team is aware of an issue affecting the Hosted Apply feature for customers on Taleo Enterprise due to recent changes from Taleo. The Phenom team is actively working on a fix. This issue is partially impacting some users, preventing them from completing their applications.
Posted Mar 20, 2025 - 19:17 UTC
This incident affected: Apply(IX) (Apply-US, Apply-EU, Apply-CA, Apply-Staging-US, Apply-Staging-EU, Apply-Staging-CA, Apply-IN, Apply-Staging-IN).