Phenom engineering team has successfully resolved the CRM Hiring Status update issue and it is working as expected. Please log a support ticket in case you still see any issues.
Posted Feb 13, 2026 - 00:55 UTC
Update
We are making progress toward resolving the delays in Hiring Status updates within the CRM. Real-time data is now being processed, while historical updates from the ATS may take additional time to fully complete. We will provide the next update in 3 hours.
Posted Feb 12, 2026 - 21:55 UTC
Update
To mitigate delays in Hiring Status updates within the CRM, we have temporarily disabled Live Sync of Candidates to LinkedIn for customers in the Production environment of the US region. Users can still perform a manual sync while we troubleshoot the issue.
We are observing a significant increase in the speed of Hiring Status updates; however, a backlog remains as the system catches up. We will provide the next update regarding these delays in 1 hour.
Posted Feb 12, 2026 - 20:56 UTC
Update
Phenom Engineering team has identified the cause of the CRM Hiring Status update issue and is currently working on a fix. We will provide another update within the next hour.
Posted Feb 12, 2026 - 19:55 UTC
Identified
Phenom has identified an issue with CRM events affecting Hiring Status updates within the Production environment for the US region. Our Engineering team is working to correct this. We will keep you posted on the progress.