Potential performance degradation in US region.

Incident Report for Phenom

Resolved

Our Engineering team has successfully resolved the issue with performance degradation in the US region and it's working as expected. Please log a support ticket in case you still see any issues.
Posted Jun 12, 2025 - 19:09 UTC

Monitoring

Our Engineering team has successfully resolved the issue with performance degradation in the US region and it's working as expected. We are currently monitoring the system.
Posted Jun 12, 2025 - 18:26 UTC

Identified

Our Engineering team has identified the cause of the performance degradation issue and are currently working on a fix.
Posted Jun 12, 2025 - 17:08 UTC

Investigating

Our Engineering team identified a potential performance degradation. We are working on it and will keep you posted.
Posted Jun 12, 2025 - 16:04 UTC
This incident affected: CRM (RX) (CRM-US).