Issue with Visits and Job Seekers Metrics In Analytics for US Region.

Incident Report for Phenom

Resolved

Phenom Engineering has resolved the issue affecting Visits and Job Seeker Metrics in Analytics for the US region.
All related data processing activities have been completed, the backlog has been fully reprocessed, and the metrics are now reflecting accurate.
Posted Mar 04, 2026 - 10:12 UTC

Update

Phenom Engineering is in the final stage of processing to resolve the issue affecting Visits and Job Seekers metrics for the US region. Due to the high volume of data, completion is now expected within the next 2 hours. Thank you for your patience. We will share another update once the process is complete.
Posted Mar 04, 2026 - 08:09 UTC

Update

Phenom Engineering is actively working to resolve the issue and address the underlying technical challenge. We expect to provide an update within the next 5 hours.
We appreciate your patience as we work to resolve this inconvenience.
Posted Mar 04, 2026 - 03:05 UTC

Identified

Phenom is currently addressing intermittent data discrepancies affecting Visits and Job Seeker metrics within the US region Analytics dashboard. While the dashboard remains accessible, our Engineering team is investigating the reporting inaccuracies. We expect to provide a progress update within five hours.
Posted Mar 03, 2026 - 21:45 UTC
This incident affected: Analytics (MX).