Intermittent issues with CRM in Prod US.

Incident Report for Phenom

Resolved

Phenom Engineering team has resolved the issue causing slowness on the CRM , and the system is now operating normally. Please submit a support ticket if you continue to experience any issues.
Posted Sep 08, 2026 - 12:03 UTC

Monitoring

We have identified the cause of the CRM intermittent slowness issue, and our engineering team has deployed a fix. We are actively monitoring the environment to confirm stability and will provide a final update shortly.
Posted Sep 08, 2026 - 11:22 UTC
This incident affected: CRM (RX) (CRM-US).