Apply Issue with Russian Data centre

Incident Report for Phenom

Resolved

Phenom resolved the issue and candidates will now be able to submit the applications for the Russian Jobs.
Posted Mar 28, 2025 - 23:02 UTC

Investigating

Phenom team has identified an intermittent apply issue with the Russian subtenant. Phenom is currently investigating the issue and We will keep you posted on the status.
Posted Mar 28, 2025 - 21:58 UTC
This incident affected: Apply(IX) (Apply-US, Apply-EU, Apply-CA).