Intermittent issues with downloading candidate evaluations in CRM

Incident Report for Phenom

Resolved

Phenom Engineering team has resolved the intermittent issues with downloading candidate evaluations in CRM and it is working as expected. Please log a support ticket in case you still see any issues.
Posted Dec 30, 2025 - 13:46 UTC

Monitoring

Phenom Engineering team has resolved the intermittent issues with downloading candidate evaluations in CRM and it is working as expected. Our Engineering team will continue to monitor for the next 30 minutes to ensure there is no further impact.
Posted Dec 30, 2025 - 13:14 UTC

Identified

Phenom has identified intermittent issues with downloading candidate evaluations in CRM for Ireland and India regions. Phenom Engineering is investigating the issue and will update in an hour.
Posted Dec 30, 2025 - 13:05 UTC
This incident affected: Interview Intelligence.