Emergency maintenance in US Production Environment

Incident Report for Phenom

Resolved

Phenom has completed the Emergency maintenance in the US Production environment. JobSync and Employee Feed Integrations are working as expected. Thank you for your continued patience and support.
Posted Feb 14, 2026 - 14:44 UTC

Update

Emergency maintenance is taking longer than expected in the Production environment for the US region, and our Engineering team is actively working on it. We will provide the another update within the next hour.
Posted Feb 14, 2026 - 13:30 UTC

Update

Emergency maintenance is currently in progress in the Production environment for the US region. We will provide an update in the next couple of hours.
Posted Feb 14, 2026 - 11:00 UTC

Identified

The Phenom Engineering team is doing emergency maintenance in the US Production environment. Customers might face intermittent delays in JobSync and Employee feed Integrations during this time. We will update once the activity is completed.
Posted Feb 14, 2026 - 09:40 UTC
This incident affected: Jobpull (IX) (Jobpull-US) and Job Feeds.