Intermittent Degraded Performance with CRM – Prod US

Incident Report for Phenom

Resolved

Phenom Engineering team has resolved the issue with CRM in the Prod US environment, and CRM is working as expected. Please log a support ticket in case you still see any issues.
Posted Feb 04, 2026 - 21:06 UTC

Monitoring

The Phenom Engineering team has resolved the performance degradation affecting the CRM, and the system is now operating as expected. The team will continue monitoring for the next 30 minutes to confirm there is no further impact.
Posted Feb 04, 2026 - 20:31 UTC

Investigating

The Phenom Engineering team is aware of and investigating intermittent degraded performance impacting the CRM production environment. Our teams are actively engaged in root cause analysis, and we will share an update within the next hour
Posted Feb 04, 2026 - 20:06 UTC
This incident affected: CRM (RX) (CRM-US).