Intermittent Issues with Hiring status In CRM application.

Incident Report for Phenom

Resolved

Phenom Engineering team has resolved the Intermittent issues with Hiring status in the CRM application, and it is working as expected. Please log a support ticket in case you still see any issues.
Posted Dec 23, 2025 - 10:47 UTC

Monitoring

Phenom Engineering team has resolved the Intermittent issues with Hiring status in the CRM application, and it is working as expected. Our Engineering team will continue to monitor for the next 30 minutes to ensure there is no further impact.
Posted Dec 23, 2025 - 10:15 UTC

Identified

Phenom has identified an issue in the IR, CA, CR and US Region services. This issue might result in Intermittent issues with Hiring status in the CRM application. Our Engineering Team is working on this issue with the highest priority and will update you on the progress accordingly.
Posted Dec 23, 2025 - 09:54 UTC
This incident affected: CRM (RX) (CRM-US, CRM-EU, CRM-CA, CRM-CR).