Proactive Notification - Potential performance degradation with Phenom Integrations services due to Scheduled release of SuccessFactors 2H 2025

Incident Report for Phenom

Resolved

We can confirm that the Integrations impacted by the SuccessFactors release are now resolved and working as expected. Please log a support ticket in case you still see any issues.
Posted Nov 15, 2025 - 10:56 UTC

Monitoring

This is a proactive notification to inform our customers about SuccessFactors upcoming scheduled release.
Due to the scheduled software release by SuccessFactors ATS, Phenom customers using SuccessFactors ATS will experience service degradation while using Phenom Integrations.
Our technical team is actively monitoring the situation and will post if any relevant updates.
For more details on the release, please contact SuccessFactors.
Posted Nov 14, 2025 - 13:59 UTC
This incident affected: Apply(IX) (Apply-US, Apply-EU, Apply-CA, Apply-Staging-US, Apply-Staging-EU, Apply-Staging-CA), Jobpull (IX) (Jobpull-US, Jobpull-EU, Jobpull-CA, Jobpull-Staging-US, Jobpull-Staging-EU, Jobpull-Staging-CA), Hiring Status (IX) (Hiring Status-US, Hiring Status-EU, Hiring Status-CA, Hiring Status-Staging-US, Hiring Status-Staging-EU, Hiring Status-Staging-CA), and Job Feeds.