Degraded performance- 2-way HSI and Job Sync

Incident Report for Phenom

Resolved

Phenom has been resolved the performance issues with 2-way HSI (Hiring Status Integration) and Job Sync and is working as expected. Please log a support ticket in case you still see any issues.
Posted Nov 06, 2025 - 14:20 UTC

Monitoring

Phenom has been resolved the performance issues with 2-way HSI (Hiring Status Integration) and Job Sync and is working as expected. We will be monitoring it for the next 30 minutes.
Posted Nov 06, 2025 - 13:49 UTC

Identified

Phenom has identified an issue resulting into degraded performance with 2-way HSI (Hiring Status Integration) and Job Sync. Our engineering team is working on correcting this. We will keep you posted on the progress.
Posted Nov 06, 2025 - 13:25 UTC
This incident affected: Jobpull (IX) (Jobpull-US, Jobpull-EU) and Hiring Status (IX) (Hiring Status-US, Hiring Status-EU).